Re: [htdig] re: Problems with iso characters


Subject: Re: [htdig] re: Problems with iso characters
From: Peter Peltonen (peter.peltonen@fivetec.com)
Date: Wed Oct 18 2000 - 03:51:43 PDT


Petri Lankoski wrote:

> > I have bit problems with htdig and iso characters and I can't find
> > solution from FAQ to my problem. Htdig DB contains 8bit

Here's how I got htdig working in Finnish (with ISO characters, that is):

1. Configured my htdig.conf:

locale: fi_FI.ISO-8859-1
lang_dir: /var/lib/htdig/common/finnish
bad_word_list: ${lang_dir}/bad_words
endings_affix_file: ${lang_dir}/finnish.aff
endings_dictionary: ${lang_dir}/finnish.0
endings_root2word_db: ${lang_dir}/root2word.db
endings_word2root_db: ${lang_dir}/word2root.db

2. Hunted the web and finally found a finnish.dict file. I copied the file
as finnish.0 to the directory I specified in my htdig.conf (I also created
that directory :). Copied finnish.aff there too. (If you cannot find these
files, I can send them to you).

3. I made a list of bad words to the file bad_words

I'm not sure if the machine running htdig has to be configured to be using
the fi-locale. I don't think so, but I changed that just to be sure.

------------------------------------
To unsubscribe from the htdig mailing list, send a message to
htdig-unsubscribe@htdig.org
You will receive a message to confirm this.
List archives: <http://www.htdig.org/mail/menu.html>
FAQ: <http://www.htdig.org/FAQ.html>



This archive was generated by hypermail 2b28 : Wed Oct 18 2000 - 03:56:47 PDT