[htdig] calculated keywords not finding their way from wrapper to htsearch


Subject: [htdig] calculated keywords not finding their way from wrapper to htsearch
From: Filippo Salustri (salustri@acs.ryerson.ca)
Date: Thu Oct 12 2000 - 21:24:51 PDT


I'm new to htDig, so I apologize if this problem is old news, but I've
looked everywhere in the web site and couldn't find anything useful

I'm running 3.1.5, and I have a Perl wrapper around htsearch. The
wrapper accepts keywords which are passed directly to htsearch, or,
alternatively, accepts certain other box and menu selections which are
then 'calculated' into a list of keywords.

I call htsearch like this:
open (IN, "$htsearch -c $digconf words='$query' | ")
where $query is a properly formed list of keywords.

If I provide keywords to the wrapper, $query is properly set, htsearch
does its thing, and I get good results.
If I use the other function of the wrapper, which calculates out the
value of $query, nothing gets passed to htsearch (I get an error
indicating no keywords were provided, and in fact the value of $(WORDS)
in the output templates is the null string.
But IN BOTH CASES, $query in the call the open is correct!

Does anyone have any ideas on what might be going on?

Thanks in advance.
Fil Salustri

--
Filippo A. Salustri, P.Eng.
Department of Mechanical Engineering, Ryerson Polytechnic University
350 Victoria St, Toronto, ON, M5B 2K3, Canada
Tel: 416/979-5000 ext 7749
Fax: 416/979-5265
Email: salustri@ryerson.ca
http://deed.ryerson.ca/~fil

------------------------------------ To unsubscribe from the htdig mailing list, send a message to htdig-unsubscribe@htdig.org You will receive a message to confirm this. List archives: <http://www.htdig.org/mail/menu.html> FAQ: <http://www.htdig.org/FAQ.html>



This archive was generated by hypermail 2b28 : Thu Oct 12 2000 - 21:27:14 PDT