RE: [htdig] RE: [3.2.0b2] AND operator not working as it should?


Subject: RE: [htdig] RE: [3.2.0b2] AND operator not working as it should?
From: Geoff Hutchison (ghutchis@wso.williams.edu)
Date: Fri Aug 04 2000 - 08:02:23 PDT


On Thu, 3 Aug 2000, Arthur Prokosch wrote:

> The word in question (say, 'fluble') is _not_ in bad_words, and is not below
> 3 characters. It's not in _any_ list. The difference in behavior has to do
> with whether a word _was ever added to the words database_, as far as I can
> tell.

So what you're saying is that there's a word in your documents that wasn't
added to the database? That would be a rather nasty bug.

> I'm kind of at a loss to explain what's going on here. I'd think that a
> loop used to AND two lists of matches together is hitting an unexpected
> boundary condition (when one list is null or something similar), but I
> didn't find the code in question with a quick search.

If it actually gets a null list (rather than an ignored word), it would
return no matches. I've verified this on both the 3.2.0b2 release and the
current snapshots.

Have you tried using htdump to look through the word database? Is the word
in there? Do the document ID values match those for pages with the other
query word?

--
-Geoff Hutchison
Williams Students Online
http://wso.williams.edu/

------------------------------------ To unsubscribe from the htdig mailing list, send a message to htdig-unsubscribe@htdig.org You will receive a message to confirm this.



This archive was generated by hypermail 2b28 : Thu Aug 03 2000 - 22:01:30 PDT