[htdig] Re: Problem restarting htdig (bug ?)


Subject: [htdig] Re: Problem restarting htdig (bug ?)
From: Paul COURBIS (Paul.Courbis@zorglub.crm.mot.com)
Date: Wed Jan 12 2000 - 10:46:26 PST


Sorry to answer to my own question but here is the solution :
I've reached a long long long URL that overflows the hardcoded
1000 bytes buffer in Retriever.cc...

                Paul

According to Paul COURBIS <Paul.Courbis@crm.mot.com> (on 01/12/00):
> Hi !
>
> When I try to restartd a dig after a signal (-l option) I get the message :
> htdig: Retriever.cc:79: Retriever::Retriever(enum RetrieverLog = Retriever_noLog): Assertion `l && buffer[l -1] == '\n'' failed.
>
> This happens wether I ran htmerge or not, but only if htdig has run
> for a long time (let say after indexing 60000 doc for example). If I kill
> and restart htdig after a short run it works...
>
> db.log was containing about 60000 url too. Htdig fails after restarting 10%
> of listed servers (monitored viewing the "New Server messages).
>
> BTW, yes I do have enough free disk space ;-)
>
> Any help would be apreciated !
>
> Paul

-- 
-=-=-=-=-  Paul COURBIS -=- Responsable Informatique / IT Manager  -=-=-=-=-=
-=-=-=-  Centre de Recherche Motorola  -=-  Paul.COURBIS@crm.mot.com  -=-=-=-
-=-         Voice: +33 (0)1 69.35.25.37  Fax: +33 (0)1 69.35.25.01        -=-
<legal>Opinions hereabove are my own and not those of my organization</legal>

------------------------------------ To unsubscribe from the htdig mailing list, send a message to htdig-unsubscribe@htdig.org You will receive a message to confirm this.



This archive was generated by hypermail 2b28 : Wed Jan 12 2000 - 10:11:20 PST