Re: [htdig] libsdtc++ problems


Jim Cole (greyleaf@yggdrasill.net)
Mon, 12 Jul 1999 21:50:38 -0600


Hi.

It is my understanding that libstdc++.so.3 is part of the newest FreeBSD
distribution (version 4.0 I believe). Previously, libstdc++.so.2 was used.
Sounds like the htdig package you are using was built under FreeBSD 4.0 and is
therefore incompatible with your libraries. Any chance of finding a package
built on an older system? If not, I guess you will need to either build the
executables yourself or upgrade something.

Jim

Peter wrote:

> I am running FreeBSD 3.1 release and installed htdig 3.1.2 via the 'pkg_add'
> feature. Attempting to run 'rundig' gives me the error:
>
> /usr/libexec/ld-elf.so.1: Shared object "libstdc++.so.3" not found
>
> 5 times.
>
> Realizing this, I installed 'glibstdc++2.8.1.1' package, but it comes up
> short.
> /usr/lib/libstdc++.a
> /usr/lib/libstdc++.so.2
>
> are the only files I see, no '3'.
>
> Am I doing something wrong? or stupid? ;)

------------------------------------
To unsubscribe from the htdig mailing list, send a message to
htdig@htdig.org containing the single word "unsubscribe" in
the SUBJECT of the message.



This archive was generated by hypermail 2.0b3 on Mon Jul 12 1999 - 20:01:42 PDT