Re: [htdig] Error Message when running "configure"


Geoff Hutchison (ghutchis@wso.williams.edu)
Tue, 1 Jun 1999 15:10:57 -0400 (EDT)


On Tue, 1 Jun 1999 KHumpf@IITRI.ORG wrote:

> configure: error: To compile ht://Dig, you will need a C++ library. Try
> installing libstdc++.

> "checking whether we are using GNU C++... yes"
> if the error message says we're not using C++ ??

The error message says you don't have the standard C++ library. It's
possible with previous versions of gcc/g++ to install the compiler but not
the library (since they were packaged separately). The more recent egcs
releases, as well as the forthcoming gcc-2.95 will install the appropriate
libstdc++ automatically.

> Can I just add the library it needs?

Yes. You don't mention what version of g++ you're using (type gcc -V to
find out), but you can get libstdc++ through the GNU ftp site:
ftp.gnu.org/pub/gnu/

-Geoff Hutchison
Williams Students Online
http://wso.williams.edu/

------------------------------------
To unsubscribe from the htdig mailing list, send a message to
htdig@htdig.org containing the single word "unsubscribe" in
the SUBJECT of the message.



This archive was generated by hypermail 2.0b3 on Tue Jun 01 1999 - 11:24:26 PDT