Re: [htdig] pdf parser error


Gilles Detillieux (grdetil@scrc.umanitoba.ca)
Mon, 15 Feb 1999 13:46:14 -0600 (CST)


According to Frank Guangxin Liu:
> My pdf indexing worked fine in htdig-3.1.0b2 and gives lots
> of errors after I updated to 3.1.0. I have the following in my conf file:
> pdf_parser: /usr/local/bin/acroread
> max_doc_size: 5000000
> ..
>
> Here are some error messages:
> Error: Can't open display:
> PDF::parse: error running pdf_parser on http://xxxxxxxxxxxx/xxx.pdf
>
> I've never seen this "Can't open display" error before. Seems like
> it wants to run X GUI Acrobat reader.
>
> Any ideas?

You should either take pdf_parser out of your configuration file, and
use the default that the configure script finds for you, or add the
following options to the pdf_parser command string:

        -toPostScript -pairs

These options used to be added to the PDF parser command line in PDF.cc,
but as they're acroread-specific, they were a problem for xpdf, so they
were moved into the pdf_parser attribute, where they could be changed
by the user.

-- 
Gilles R. Detillieux              E-mail: <grdetil@scrc.umanitoba.ca>
Spinal Cord Research Centre       WWW:    http://www.scrc.umanitoba.ca/~grdetil
Dept. Physiology, U. of Manitoba  Phone:  (204)789-3766
Winnipeg, MB  R3E 3J7  (Canada)   Fax:    (204)789-3930
------------------------------------
To unsubscribe from the htdig mailing list, send a message to
htdig@htdig.org containing the single word "unsubscribe" in
the SUBJECT of the message.



This archive was generated by hypermail 2.0b3 on Wed Feb 17 1999 - 10:10:03 PST