Re: [htdig] result error


Geoff Hutchison (ghutchis@wso.williams.edu)
Fri, 12 Feb 1999 15:47:25 -0500 (EST)


On Fri, 12 Feb 1999, Eric Luhrs wrote:

> Today I compiled htdig 3.1.0 and installed it. I got an error while
> htdigging, so I backed out the installation, and put the previous version

You don't mention what your error is. Most of the bugs reported in 3.1.0
have now been fixed and will be part of a 3.1.1 release shortly.

> What the heck happened? This is on a semi-production server, and what I
> thought would be a quick test/upgrade has backfired in a big way....
> It seems that the DB is really scrambled. Any ideas?

Often when I "back out," I forget that I also installed a new version of
htsearch. Since several database-related bugs were fixed in 3.1.0, a newer
version of htsearch assumes those bugs are not present and will often be
unable to find data in the buggy databases.

Another potential problem is your rundig script. My personal rundig script
only does update digs, since it's much faster. But if you made any
modifications to your databases, the older htdig could get quite confused
for reasons similar to those I outlined above.

Cheers,
-Geoff Hutchison
Williams Students Online
http://wso.williams.edu/

------------------------------------
To unsubscribe from the htdig mailing list, send a message to
htdig@htdig.org containing the single word "unsubscribe" in
the SUBJECT of the message.



This archive was generated by hypermail 2.0b3 on Wed Feb 17 1999 - 10:10:03 PST