Re: [htdig] htdig errors please help...


Peter Polkinghorne (Peter.Polkinghorne@brunel.ac.uk)
Thu, 04 Feb 1999 10:01:54 +0100


>
> Hello all,
>
> I'm new to htdig, please take it easy on my questions:
>
[SNIP]
> 2. I ran ./rundig on one site and it generated a database, a few days
> later I modified the htdig.conf file for second site and tried to ./rundig
> again and the database of the first site was lost. Do I have to use
> ./rundig for every site at once? Can I just append the second index to the
> first one? I have tried it with ./htdig -a followed by ./htmerge ....
> command w/o any flag. Please tell me what I have done wrong?
>
>
> Thank you,
>
> Kenny

The problem is that rundig is really a first time script - plus it has in
htdig-3.1.0b4 a missing fi at the end and the -nt test (presumably newer than)
which does not exist in Solaris 2.5.1 Bourne Shell - a bashism?

To do incremental indexes you need 2 things (I believe - correct me if wrong):

a) use -a flag to build alternate files for htdig & htmerge

b) leave the work files around - so cp *.work -> *

The script I use is appeneded - paths will have to change.

-- 
-----------------------------------------------------------------------------
| Peter Polkinghorne, Computer Centre, Brunel University, Uxbridge, UB8 3PH,|
| Peter.Polkinghorne@brunel.ac.uk   +44 1895 274000 x2561       UK          |
-----------------------------------------------------------------------------




This archive was generated by hypermail 2.0b3 on Wed Feb 10 1999 - 17:09:05 PST