Re: htdig: Slashes in query string causing loops


Matthew Whalen (mwhalen@uucom.com)
Tue, 22 Dec 1998 10:15:21 -0500


When I was running 3.1.0b2, I had exactly the same problem. Everything was
working fine for weeks, then one night this started happening. My
configuration hadn't changed, nor had any of the scripts which create
dynamic content on my web server. I ended up crafting some excludes
which solved the problem, but it was annoying and bothersome. I have no
idea what caused it.

-matthew

I think I heard "Adam Coyne" say:
>I just upgraded to 3.1.0b3 (and applied the memory leak patches), and I'm
>having a problem where htdig gets into an infinite loop. My home page is
>/index.asp. It has a bunch of links to itself with different dates in the
>query string, such as:
>
>/index.asp?date=11/21/98
>
>After htdig finishes indexing the pages for each date, it begins indexing
>urls looking like this:
>
>/index.asp?date=11/21/index.asp?date=12/1/98
>
>It appears to be interpreting the final slash to mean a subdirectory, even
>though it's after the question-mark. Doesn't seem quite right.
>
>--
>Adam Coyne -- adam@criticalmass.com
>
>----------------------------------------------------------------------
>To unsubscribe from the htdig mailing list, send a message to
>htdig-request@sdsu.edu containing the single word "unsubscribe" in
>the body of the message.
>

----------------------------------------------------------------------
To unsubscribe from the htdig mailing list, send a message to
htdig-request@sdsu.edu containing the single word "unsubscribe" in
the body of the message.



This archive was generated by hypermail 2.0b3 on Sat Jan 02 1999 - 16:29:55 PST