htdig: Virtual Domains NOT being Indexed....


Shooters Web Master (webmaster@s0.shooters.com)
Fri, 12 Jun 1998 14:32:55 -0400 (EDT)


Hi -

After much poking around in the code, I have come to the conclusion
that "I have to ask"...

I'm webmaster of an ISP that hosts over 400 domains (432 to be exact)
on only 137 IP addresses (Thank you Apache).

But it has been brought to my attention that all of the "stacked IP domains"
(the term that we use for Domain Names that share an IP address, but contain
different content) endup being "ht:Dug" as the "IP address" (which IS NOT the
Apache Served content for each of the domains).

It seems that the Connection server setup is asking for the correct domain name
and the HTTP request looks correct, but the socket is getting setup to be
talking to the IP and NOT the "IP/domain name".

I understand the "logic" of the problem, but I DONT know how to get the socket
to bind the Apache such that the virtualy served content is sent back.

"Browsers" (IE/Netscape/"others") Don't seem to have a problem, but hi:Dig
does.

In short....
HELP!

-- 
cg
  ...................... ..........................
 /                      |                          \
|  Shooters' Webmaster  | http://www.shooters.com/  |
|\......................^........................../|
| |     Working to keep the Shooting World        | |
 \|            On-Line and On Target              |/
  +-----------------------------------------------+

---------------------------------------------------------------------- To unsubscribe from the htdig mailing list, send a message to htdig-request@sdsu.edu containing the single word "unsubscribe" in the body of the message.



This archive was generated by hypermail 2.0b3 on Sat Jan 02 1999 - 16:26:33 PST