Re: [htdig3-dev] Transport code broken

Subject: Re: [htdig3-dev] Transport code broken
From: Gabriele Bartolini (
Date: Fri Feb 11 2000 - 01:29:22 PST

In 11.51 10/02/00 -0500, Geoff Hutchison ha scritto:
>> a server. Gabriele asked me to check since he experienced the same problem
>> and I confirm this.
>This is a bit strange and I'll investigate futher when I have a chance,
>but I would suspect the culprit is in

>+ retry_value = 0;

>So I'd set the default to 1. This is probably what it should be anyway,
>but the code should be setting retry_value to a nonzero value elsewhere.

Can you explain me how retry_value works? It's different, I suppose, from
the "max_retries" configuration value and it's not tied with it, I guess.

As far as I am concerned, I think we manage the number of retries on a
higher level (that is to say on the code that wants to retry for a
document, isn't it?).

If we use "max_retries" probably "retry_value" is a logical duplication and
so it's unuseful (I think it should alway be always 1 ...). But probably, I
repeat, I need more explanations about this.

Anyway, the actual code seems to work ... even if I don't know why
"timeout" value is not always respected. We need to go over the Connection
code, but I don't think to be very keen on it !!! (can I use this
expression??? - to be keen on ...)



Gabriele Bartolini
Computer Programmer - supposed to be ;-)
U.O. Rete Civica - Comune di Prato
Prato - Italia - Europa


Luna Rossa Prada Challenge - America One 5-4 ;-D

To unsubscribe from the htdig3-dev mailing list, send a message to
You will receive a message to confirm this.

This archive was generated by hypermail 2b28 : Fri Feb 11 2000 - 01:34:44 PST